]> git.karo-electronics.de Git - meta-kc-bsp.git/blobdiff - recipes-bsp/dotsplash/dotsplash_git.bb
dotsplash: Improve start script and psplash compatibility
[meta-kc-bsp.git] / recipes-bsp / dotsplash / dotsplash_git.bb
index 7bbe11e31aa53e62b1ad37fec11ed4ca51e8c4ee..6bce9d6c9f10d33d631fb7c894fc78d6fdfd890d 100644 (file)
@@ -1,7 +1,7 @@
 SUMMARY = "./dotsplash - a tiny and customizable splash screen"
 LICENSE = "GPLv2"
 PV = "1.0+git${SRCPV}"
-SRCREV = "eac58fd508efaa3215094085daa06a58d6d7a75c"
+SRCREV = "1555cb1a1c68c5c5536c3222ecd73783f7d9e74d"
 
 
 LIC_FILES_CHKSUM = "file://COPYING;md5=39bba7d2cf0ba1036f2a6e2be52fe3f0"
@@ -16,18 +16,20 @@ inherit pkgconfig update-rc.d meson
 
 S = "${WORKDIR}/git"
 
-FILES_${PN} += "/mnt/.dotsplash/"
+FILES_${PN} += "/mnt/.psplash/"
 
 PACKAGES =+ "${PN}-themes"
 FILES_${PN}-themes += "${datadir}/dotsplash/themes/*"
 
 do_install_append() {
-    install -d ${D}/mnt/.dotsplash/
+    install -d ${D}/mnt/.psplash/
     install -d ${D}${sysconfdir}/init.d/
     install -m 0755 ${WORKDIR}/dotsplash-init ${D}${sysconfdir}/init.d/dotsplash.sh
     install -d ${D}${sysconfdir}/default/
     install -m 0644 ${WORKDIR}/dotsplash-default ${D}${sysconfdir}/default/dotsplash
     install -m 0755 ${WORKDIR}/splashfuncs ${D}${sysconfdir}/default/splashfuncs
+    cd ${D}/${bindir}
+    ln -s dotsplash-write psplash-write
 }
 
 INITSCRIPT_NAME = "dotsplash.sh"